Ticket #170 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

libBlitzBioFormats 1.0 RC1 fails on Mandriva

Reported by: emmenlau Owned by: emmenlau
Priority: major Milestone:
Component: libBlitzBioFormats Version:
Keywords: Cc: aaron.ponti@…, patrick.schwarb@…, developers@…

Description

Original reporter: Aaron Ponti.

this is what I get in Linux (Mandriva...) when I try to create the VM:

BlitzBioFormatsViewerGUI::OnSetLibrary(/home/aponti/Programs/BlitzBioFormatsViewer-r3760/bin/blitzbioformats.jar, 64):
Caught exception when creating new BlitzBioFormats instance.

Exception caught when creating Java Virtual Machine with classpath
'/home/aponti/Programs/BlitzBioFormatsViewer-r3760/bin/blitzbioformats.jar' and heap size '64'.
Error message 'Assert failed: Unable to find the class, jace.util.ShutdownHook.'. 

Change History

Changed 10 years ago by emmenlau

  • status changed from new to closed
  • resolution set to fixed

I could not reproduce this issue so far, but I could reproduce a user error that triggers identical behavior. On Linux, the start script lists the following default blitzbioformats.jar:

BlitzBioFormats-x86_64-rXXXX/bin/blitzbioformats.jar

However, correct would be (note the "bin" versus "lib"):

BlitzBioFormats-x86_64-rXXX/lib/blitzbioformats.jar

So the user has to manually correct the path. If he/she does just press "Apply", then the blitzbioformats.jar can not be found (due to the wrong path). I have implemented a fix that replaces "bin" with "lib" in the installation path, however that is not a bugfix but rather an ugly hack :-)

Closing the bug as fixed, please reopen if the issue remains.

Changed 10 years ago by emmenlau

Fixed in changeset:3829

Note: See TracTickets for help on using tickets.