Ticket #63 (closed defect: worksforme)

Opened 11 years ago

Last modified 11 years ago

xuvtools: stitching fails for lsm dataset in exhaustive search

Reported by: emmenlau Owned by: emmenlau
Priority: major Milestone:
Component: xuvtools Version:
Keywords: xuvtools, error Cc: niko@…

Description

Stitching fails for the lsm dataset Cycle001Tile000097.lsm, Cycle001Tile000098.lsm in exhaustive search.

Happened to Niko Ehrenfeuchter, ne704.

Attachments

Cycle001Tile000097-Cycle001Tile000098.jpg Download (72.3 KB) - added by emmenlau 11 years ago.
stitching of two tiles

Change History

Changed 11 years ago by emmenlau

Dataset at xuvtools.org:/data/xuvtools_img/BugListData/Bug0063

Changed 11 years ago by emmenlau

stitching of two tiles

Changed 11 years ago by emmenlau

  • status changed from new to closed
  • resolution set to worksforme

Stitching works for me with low threshold of 0.35 (probably due to noise?)

From the ConfigMap? / Logfile:

/data/xuvtools_img/BugListData/Bug0063/Cycle001Tile000097.lsm_filetype 6
/data/xuvtools_img/BugListData/Bug0063/Cycle001Tile000098.lsm_filetype 6
bleachcorr_width_pix 10
blending_width_pix 10
fftw_plan_flags 0
find_abs_positions_threshold 0.5
fixed_window_radius_pix 16,64,64
gui_grid_mode 0
gui_grid_overlap 0
importance_sampling_steps 20
log 1
log_dir /home/emmenlau
moving_window_radius_pix 4,16,16
number_of_threads 1
outputfile_compression 3
overlay_add_mip 0
overlay_drawborder_brightness -1
overlay_drawcolor 0
phase_sampling_abort_value 0.6
phase_sampling_steps 1
phasecorr_downscaling 0.55
projectfilename 
projectname Untitled
scene_alpha 0.7
scene_gamma 1
scene_intensity_bounds 0,65535
signed_data 0
smoothing_parameter 0
[...]
tilecounter 2
tiles tile0001,tile0002

The tiles overlap in um from (-1264.8,-449.999,349.999) to (1264.8,446.874,449.999)
  and in movingArrPixels from (0,0,455) to (172,509,511), that is 3 [ 172 509 56 ] pixels.

connected components-test found for thresh 0.35:
(0,1) x (0,1)
[ 0 0.366605 
  0 0 ]
 0  1 
 1  1 

chiSquare = 0.0000
chiSquare = 0.0000
chiSquare = 0.0000
stack[0]: (0.0000,0.0000,0.0000)
stack[1]: (0.0000,0.3906,799.9990)

Changed 11 years ago by ne704 [niko@…

I can confirm the successful stitching when reducing the threshold to something below 0.40 - oddly enough this isn't required when using the 32Bit xuvtools, here the stitching works with default settings (0.50), so maybe we should reopen this ticket and dig a little deeper at this situation...?

Cheers,

Niko

Note: See TracTickets for help on using tickets.