Ticket #65 (closed enhancement: fixed)

Opened 11 years ago

Last modified 10 years ago

xuvtools: [wishlist] window title should reflect name of a loaded project-FILE

Reported by: ne704 [niko@… Owned by: ne704
Priority: unimportant Milestone:
Component: xuvtools Version:
Keywords: xuvtools, xuvtools_gui, wishlist Cc: developer@…

Description

Currently, the window title shows the name of a project that was assigned to it when the project was saved the first time. If you rename the saved project-file later, this name won't be shown in the GUI when you load the renamed project, instead the original name is still used in the window title. I'd think it is pretty useful to have the actual filename displayed as well (maybe in brackets behind the project-name).

Cheers, Niko

Change History

Changed 11 years ago by ne704

  • priority changed from major to trivial

Changed 11 years ago by ne704 [niko@…

The .h5-fileformat/xuv-project-class makes a difference between projectfilename and projectname which can lead to confusion if a project-file is renamed outside of xuvtools_gui, I think this should be somehow simplified.

I'd expect the project-name to be the same as the filename, since this is what happens in the other direction, when a project is saved...

Plus, there's already a function that returns a project-name from the corresponding filename (xuvtools_gui/src/project/project.h):

QString projectNameFromFileName( QString projectFileName );

Changed 10 years ago by ne704

  • cc aponti@…, mario@… removed
  • status changed from new to assigned

Changed 10 years ago by emmenlau

  • cc developer@… added; niko@… removed
  • keywords xuvtools_gui, added
  • status changed from assigned to closed
  • resolution set to fixed

Can you please check if this is still an issue, and re-open the bug if the problem still exists?

I have not changed anything in setting the project name, but I have made several changes in reading/writing projects. I could not reproduce the problem, and (from a quick look) think it should be solved.

Note: See TracTickets for help on using tickets.