Ticket #67 (closed defect: worksforme)

Opened 11 years ago

Last modified 10 years ago

xuvtools: GUI crashes *sometimes* when loading large datasets

Reported by: ne704 [niko@… Owned by: emmenlau
Priority: major Milestone:
Component: xuvtools Version:
Keywords: xuvtools, error Cc: developers@…

Description

This is a really ugly bug :-(

The xuvtools_gui (RC3/r2746) crashes sometimes when loading large datasets (approx. 5-8GB) on Win64. Reopening the GUI again and re-loading the same dataset works. I know this is a terrible bugreport since it says "there is some problem out there, fix it!", but I tried to hunt it down to something more precise, yet I had no luck...

  • there's still loads of free memory ( > 25GB)
  • sometimes it works, sometimes it crashes with the same files
  • the logfiles are empty (besides the well-known "BZ_THREADSAFE is not defined." in "stitcher_log"

Maybe there's a problem in how memory-allocation is done? Kind of "Windows is not allocating fast enough under certain situations"....? Any other ideas?

How can I debug this any further?

Niko

Change History

Changed 11 years ago by ne704 [niko@…

just to be accurate: verbosity is set to 9, logfiles are re-created when the GUI starts...

Changed 10 years ago by emmenlau

Can you please try to re-validate this bug?

I will outdate this bug in one week if it receives no updates, but do not mind - if the error should happen again, just re-open this bug, or create a new one!

Changed 10 years ago by ne704 [niko@…

  • status changed from new to closed
  • resolution set to worksforme

Haven't suffered from this bug for quite a while, so closing it as worksforme.

Note: See TracTickets for help on using tickets.