Ticket #97 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

The progress bar does not update anymore

Reported by: aaron@… Owned by: emmenlau
Priority: minor Milestone:
Component: xuvtools Version:
Keywords: xuvtools, xuvtools_gui, error Cc: niko@…, mario@…, aaron@…

Description

Status at revision 3013.

Change History

Changed 11 years ago by ne704 [niko@…

I can confirm the progress bar isn't updating any more during a stitcher run. It still works on generating thumbnails.

Tested with r3048 (1.6.0).

Changed 11 years ago by ne704

  • cc niko@…, mario@…, aaron@… added
  • keywords xuvtools, xuvtools_gui, error added
  • priority changed from major to minor

Changed 11 years ago by aaron@…

I think the following is the reason why the progress bar stopped working. I suggest Mario tries to restore this functionality through the reporter library.

In revision 2907, the following methods were removed from the class Thread:

void Thread::progressCallback( const int current, const int max )
{
    emit updateProgressRequested( current, max );
}

void Thread::progressCallback( const float startProgress,
        const float endProgress, const float loopTotalIterations,
        const float loopCurrIteration, const float maxProgress )
{
    emit updateProgressRequested( startProgress, endProgress,
        loopTotalIterations, loopCurrIteration, maxProgress );
}

These were used to let the threads (i.e. xuvstitch) communicate to the user interface that the progress bar should be updated. Since they are gone, the updateProgressRequested signal is never emitted.

Changed 11 years ago by emmenlau

  • status changed from new to closed
  • resolution set to fixed

Fixed in r3125:

  • replaced diverse hardcoded progress bar update methods, with generic libReporter progress logging (affects most GUI classes)
  • removed title bar from progress bar, and centered text

Changed 11 years ago by ne704 [niko@…

Confirmation, works again. And I like the new design of the progress-bar. :)

Note: See TracTickets for help on using tickets.