Ticket #99 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

xuvtools: fails to display *some* LSM files

Reported by: ne704 [niko@… Owned by: emmenlau
Priority: minor Milestone:
Component: xuvtools Version:
Keywords: xuvtools, xuvtools_gui, error Cc: mario@…, niko@…, aaron@…

Description

current trunk (r3014) fails to open some LSM files correctly.

More precise, this means they are opened without any error message, but the displayed tiles have no size (generating thumbnails has no effect). Opening the same files with e.g. Imaris shows they have a reasonable content.

I'll upload affected files in a moment.

Change History

Changed 11 years ago by ne704 [niko@…

excerpt of the dataset is availble here:

xuvtools.org:/data/xuvtools_img/BugList/Data/Bug0099/

Changed 11 years ago by emmenlau

  • cc niko@…, aaron@… added
  • summary changed from xuvtools: fails to open *some* LSM files to xuvtools: fails to display *some* LSM files

This bug is interesting. Opening the files works for me on Linux (tried r3127), and thumbnails suggest the stacks are ok. On Windows, I can see the stitcher is doing something, and coordinates for the 6 stacks are shown in the position editor. However, the stacks appear very very small (i.e. I can see some blue dots in the center of the screen, that turn red when I select them with the mouse).

I think the real bug might be "display of stacks broken".

No clue to the reason, though.

Update: The stacks have voxel size 0.219727, 0.219727, 0. I think voxel size 0 in Z direction could be a hint to the problem.

Changed 11 years ago by emmenlau

  • status changed from new to closed
  • resolution set to fixed

The problem is indeed the voxel size reported by libBioFormats. There should not be a voxel size of '0', else the GUI seems to fail placing the tile on screen.

Fixed in GenFile?.cc, revision r3151, by adjusting voxel size to 1.0 if less than 1e-10 is reported.

Fixed not in xuvtools_gui, so the problem might still exist with other filetypes!

Note: See TracTickets for help on using tickets.